Air Recirculation not working - no indication light, nothing

edubya32

Member
Joined
Jan 2, 2024
Messages
61
Reaction score
31
Location
Denver
Military
Navy Vet
Current Ride
2023 Tremor 3.5EB | 402A | Torsen
Current Ride #2
2021 BMW X5 X40i
So, I was sitting behind an old jeep getting gassed out, so I went to turn on recirculate, when I hit it, nothing happens, there's no indication light on the button, no indication on the infotainment screen...

The heat was on at the time, trying to troubleshoot I thought maybe it only works when the AC is on, so I tried that, nope.

What am I missing?
 
I don’t ever use it,but I’m pretty sure i read on the interweb it was a summer feature for AC when I was trying to figure out what the purpose of it really was.
 
So, is there a light or other indicator that I should have when pushing the button?
 
I’ll check mine tomorrow morning and report back to you.
 
i figured it out - must be in "auto" mode then you can select and activate recirculation. I'm not sure why auto mode is a requirement, but whatever.
 
i figured it out - must be in "auto" mode then you can select and activate recirculation. I'm not sure why auto mode is a requirement, but whatever.
Gotcha…well glad you got it figured out.
 
I tested mine out lastnight and didn’t need it to be in auto to work. Had the settings on defrost and feet,hit the circulate button and it immediately lit up on the button for me,temp setting was at 22C…weird.
 
I don’t ever use it,but I’m pretty sure i read on the interweb it was a summer feature for AC when I was trying to figure out what the purpose of it really was.
In extremely hot conditions, it recycles cabin air (already cooled) rather than introduce more hot humid outside air, for quicker cooling and ultimately better efficiency. For safety reasons, I believe some outside air is allowed to bleed in to prevent hypoxia!
 
So, I was sitting behind an old jeep getting gassed out, so I went to turn on recirculate, when I hit it, nothing happens, there's no indication light on the button, no indication on the infotainment screen...

The heat was on at the time, trying to troubleshoot I thought maybe it only works when the AC is on, so I tried that, nope.

What am I missing?
It should ONLY be used in conjunction with A/C as recycled breath will cause windows to fog up, whereas A/C will condense humidity. See my other answer above. Having said that, it "could" be malfunctioning, but try it in MAX DEFROST (A/C is on by default).
 
Last edited:
One thing I have noticed is that it will also only stay on for ~5 min. Have a couple mills I drive by daily and took me a while to realize. Even on auto and a/c.
 
I tested mine out lastnight and didn’t need it to be in auto to work. Had the settings on defrost and feet,hit the circulate button and it immediately lit up on the button for me,temp setting was at 22C…weird.
hmmm, ok, I'll have to try that, but I did already try having the AC turned on, I would think that would have been enough, but I'll try again.
 

New Topics

Back
Top