Dash Shuts Off

BoostKing

Active member
Founding Member
Joined
Oct 6, 2021
Messages
126
Reaction score
156
Location
Florida
Current Ride
2022 F150 Tremor
Current Ride #2
2018 Mustang 5.0
I made a video yesterday after discovering that my dash would shut off if I tried to view the Trailer Tire Info screen. This also resets the dash, and the My View and gauge orientation. Does this happen to any of you? 402a truck

Video's to see what I am talking about

 
I was towing last weekend and mine did the same thing. Tried it a few times and every time it shut off and completely reset.
 
Mine does the same, discovered that a few weeks ago. Mine is a 22 402A, trailer tow package.
 
Anyone take it to the dealership? I called mine, they said they hadn't heard of it. I assume non-Tremor F150's may have the same issue.

I can live with it short term, and let others be the guinea pig for figuring out a solution. Just annoying.
 
So mine does same thing and I took it too dealership ( you guys can thank me later). Three weeks later still no fix as a matter of fact they have fucked it up. Ordered a new cluster but it was wrong cluster ford doesn’t have any for the tremor currently and now truck throwing all kinds of codes and can’t be driven. They don’t know when a new cluster will be available and if that’s even the problem I will keep everyone posted. Don’t take too dealer I’m your Guinea pig!!!
 
Well good to know, won’t be taking to dealer! I don’t really need to see trailer info anyways.
 
Mine does the same thing. Scared the crap out of me the first time I discovered it. I was on the highway doing about 75MPH and the display went out.
I had it at the dealership for it last week, it isn't fixed. But the dealer is working with Ford on the issue.
The dealer said they will get back to me when Ford provides an answer.
 
Geez that's Crazy. I havent had the cluster shut off but maybe 5 or 6 times while on the phone using the bluetooth,my infotainment system shuts off and totally reboots like that. Anyone had that issue also?
 
So mine does same thing and I took it too dealership ( you guys can thank me later). Three weeks later still no fix as a matter of fact they have fucked it up. Ordered a new cluster but it was wrong cluster ford doesn’t have any for the tremor currently and now truck throwing all kinds of codes and can’t be driven. They don’t know when a new cluster will be available and if that’s even the problem I will keep everyone posted. Don’t take too dealer I’m your Guinea pig!!!
WOW!!! This is terrible. I just saw your post today and I had my truck in for this issue last week. It looks like I got lucky and my dealer didn't try to change the cluster. Thanks for the heads up.

Do you have any updates?
 
WOW!!! This is terrible. I just saw your post today and I had my truck in for this issue last week. It looks like I got lucky and my dealer didn't try to change the cluster. Thanks for the heads up.

Do you have any updates?
I just tried it this morning on the way to work and it didn't happen to me. I tried it several times in different ways. I have a '21 with 402a with the tow package.
 
I just tried it this morning on the way to work and it didn't happen to me. I tried it several times in different ways. I have a '21 with 402a with the tow package.
This is good information...
Mine is a 22 with 402A and tow package. I wonder if it's a 2022 only issue.

It would be useful if others let us know if they do or don't have the issue and what year truck they have.
 
This is good information...
Mine is a 22 with 402A and tow package. I wonder if it's a 2022 only issue.

It would be useful if others let us know if they do or don't have the issue and what year truck they have.
That's what I was thinking as well, but I am not aware of any real differences between the model years. Now, I have not dug into the topic yet either to be fair.
 
I do not believe this is a hardware issue so don’t replace anything till Ford says so. This is very likely a software issue.
 
For my 402a 2022 it happens when I select “trailer tire info” under the towing menu. The screen will freeze then go black. About 5 seconds later the built ford tough animation will start but it is super laggy and eventually the screen comes back.
 
402a 2022 dash resets when I select "trailer tire info" under towing menu. I thought at first my forscan changes may have caused some erroneous issues, but this seems widespread.
 
I told my dealer about this and they said they didn't have any info on it. They wanted me to bring it in, but I told them I would when I bring it back to fix an interior defect. I'm only going to let them look at it, not try to fix it. That appointment is next Friday.

I also asked them to keep an eye out for any loaded 2022 trucks to try it on. Something comparable to the trim on the Tremor (402a and tow package) to see if it's not just isolated to Tremor's. I suspect it's not just us.
 
Haven't tried that button yet to see if my 402a does that, but I have had 2-3 of the small gauges randomly disappear from time to time. Will have to check out the reboot screen to see.
 
Today on the way to and again from work I tried every combination of selecting everything towing related from within and from outside the towing menu, nothing happened. Again, I have a 2021 402a high towing the whole nine
 
Can confirm mine shuts off then resets and recycles the whole dash screen.

‘22 402A fully loaded (without Blue Cruise)

Hopefully there’s a fix for this soon.
 
Tried messing with trailer settings today like you e said causes it and sure enough, my 22 402a does it too. Shuts down and reboots the cluster. Add me to the list
 

New Topics

Back
Top