A/C Issues

Mine has "frozen" in Auto mode and Manual mode with Recirc Off and On. The service writer did ask me if it only froze in Recirc mode so that seems to be something they are keying on.

mine has done the same...I forgot to mention, one of them told me that 70 degrees and up kept things from freezing...regardless, it happened to me with 350 miles, then again at 1000...I'm now at 1500 and it hasn't happened since the last time and I've run it a bit.

IDK, I kinda want to put off taking it in until they've really realized what the issue is. Reading that others have had it "fixed" and it's still an issue is frustrating.
 
Agreed. Very frustrating. My issues started, from day 1, with loud "cracking" noises, behind the dash at startup but I didn't take it in until the freeze-up issues started. They diagnosed the noise as faulty blend doors and replaced the evaporator core. The truck was in the shop for 10 days. Freeze up issues have mainly occurred on longer drives but that is precisely when you don't want something like that to happen, particularly in the 95+ degree heat wave we've been having. Truck was back in the shop for 3 days to get the "evaporator valve" replaced. Hoping this is the final trip but always a chance they are just replacing parts and hoping for a fix.
 
Same problem here. Had it happen a few times. Mine happen on trips less that 30 minutes though. It will be going to the dealer as soon as it happens again. Anyone know if the codes will be there from before?
 
Not sure if there was a code for the evaporator valve. The dealer was supposed to e-mail me the work ticket but haven't seen it come through yet.....sorry.
 
Currently at the dealer now. Service advisor just called and it looks like they are gonna have to pull the dash as something in that evaporator core is freezing up. He said they will know first thing tomorrow on what parts to order and how long the work will take. Bought the truck in May and have 6K miles. This sucks.
 
Had mine less than 1 month and 1K miles when the dealer had it for 10 days replacing the evaporator core. That fixed the "cracking" noises at start-up but did not solve the freeze-up issue. The second, 3 day dealer visit replaced the evaporator valve. Have not taken the truck on a road trip since but working fine, so far.
 
Had mine less than 1 month and 1K miles when the dealer had it for 10 days replacing the evaporator core. That fixed the "cracking" noises at start-up but did not solve the freeze-up issue. The second, 3 day dealer visit replaced the evaporator valve. Have not taken the truck on a road trip since but working fine, so far.
Unlike you there were no odd noises associated with my issue. It’s does happen on longer drives in warm weather. Service advisor did relay they’ve had a few trucks with this issue so, at the very least, they know it’s an issue and I’m being taken seriously. Service advisors always look at you sideways when it’s not an easily replicated issue. I’m just hoping this isn’t a ten days issue.
 
I do not think the 2 issues were necessarily related. The noises, according to the dealer, were coming from 2, stripped mode doors in the evaporator core. Since the noise was there from day one, I am guessing it was a faulty part from the factory. The truck seemed fine, afterward, until I took it on a 4 hour road trip and it froze-up 3 hours into the trip. I had already figured-out how to get it back working, from the first far from home episode, but annoying to have to turn the A/C off, wait 5 minutes and then turn it back on. On the 4 hour trip back, it froze-up 3 times. The dealership has been good about jumping on it, both times, but I am also a multi-repeat customer since 2015. Probably shouldn't matter but it likely doesn't hurt.
 
I have also experienced the freezing problem with no cold air on several occasions. (I did not have the cracking noises). I finally got it to the dealership when it was 'frozen'. They documented the problem and I'm scheduled for a new evaporator core and sensor on Thursday. I'll keep you posted.
IMG_7184.jpeg
 
Well, it happened again on the way home from work, yesterday. Raining and 77 degrees and the A/C froze up on my 15 minute commute home. This is becoming a bad dream......
 
Dealership just called and confirmed the repair. A/C freezing up.
 
I hope you have better luck. Evaporator Core and Valve replaced, so far, and still freezing up..........highly frustrating. I am generally pragmatic about vehicles and issue, realizing they are mass-produced and subject to any number of possible faults but A/C systems are nothing new and this issue does not appear to be uncommon with the current F150.....something is amiss.
 
I hope you have better luck. Evaporator Core and Valve replaced, so far, and still freezing up..........highly frustrating. I am generally pragmatic about vehicles and issue, realizing they are mass-produced and subject to any number of possible faults but A/C systems are nothing new and this issue does not appear to be uncommon with the current F150.....something is amiss.
Same exact symptoms? Airflow reduces or anything else?
 
Yes, the symptoms have always been the same. In Auto or Manual, the A/C air volume slowly goes to nothing, regardless of fan speed. It will typically come back, after the truck sits for some time but I have also found that if I turn off the A/C button, and wait a few minutes, airflow will start again, air will be cold even though the A/C is off, and I wait until the air starts to warm up and then turn the A/C button back on and will typically blow cold from that point. However, on a recent 250 mile trip, prior to them replacing the evaporator valve, I had to do this routine 3x in 4 hours.
 
Yup. Same symptoms with less frequency. Even with the evap core and valve the issue remains?
 
Yes. Happened on the way home from work, yesterday. 15 minute ride in 77 degree, raining weather. System was in manual mode with recirc on. Unfortunately, it was after 6:00 PM or I would have taken it straight to the dealer. A/C worked normally on ride in this morning.
 
Frustrating.

They’re ordering my parts today and hoping to have the vehicle back by Friday they said.
 
Any updates from folks who have had A/C freeze-up issues and been through the dealer service shop? I've had both the evap core and evap valve replaced and still occasionally having the A/C freeze-up. Service Manager has basically said nothing else they can do until Ford comes up with a solution. They are thinking it maybe a software glitch. He did say they had several '23 trucks having the same issue.
 
I had mine replaced and haven’t had any further issues to date. Time will tell. It’s interesting how every dealer seems to have a different comment on this problem.
 
It is very frustrating. Dealer has been OK but are putting it off on Ford now. I drove the truck to a HS football game, Friday evening, about a 30 minute commute, each way, and it froze-up going there and coming back. Last week, on a longer trip (+/- 2 hours each way) it never really froze up completely but the air volume would go down to almost nothing and then, randomly, start blowing 3x harder (this was in manual mode with the fan on a set speed, not in Auto mode). Even my wife made a comment about how odd the A/C was working.
 

New Topics

Back
Top